ハードウェア

Intel Celeron N2830が重い件

最初に、今から書くことは他のパソコンを触らせていただいた時のことなので、
質問などがあっても、このエントリー以上にフォローをさせていただくことができません。 
ただ、新しいパソコン買ったんだけど・・という方への情報として、絶対に必要なことだと思い書きました。
画像などもありません。

まず経緯として、とある新しいノートパソコンを設定させていただく機会がありました。
設定を始めました。最近のパソコンなのでWindows8.1です。
最初のスタート画面が表示されるまでは長いものです。
「あともう少しです」
に変わってからの、もう少しじゃない感は非常にイライラしますが、
なんとか待ってスタート画面が表示されます。やったー!

ここからマウスを挿して設定開始だ!
・・あれ、インストールまで長いな。
セキュリティソフト無効化して、Office設定開始だ!
・・普段よりなげーな。
無線設定してネット
・・起動遅い、表示遅い、検索してみようと入力→固まる

パソコンの動作が重い時は、まずタスクマネージャーを起動します。
(タスクマネージャーは、タスクバーを右クリック→「タスクマネージャー」で起動できます)

CeleronN2830遅い件_002



















Windows8からのタスクマネージャーは、こんな感じでHDDやネットワークの情報が出てきて、
最初から見やすくなっています。
Windows7ではリソースマネージャーを見る必要がありますね。
このタスクマネージャーは私のパソコンのもので設定したパソコンのものではありません。 

パソコンが重くなる原因はいくつか有りますが、ハードディスクへのアクセスが多くて
重くなっていることが多いです。
上の画像で言うと「ディスク0」の部分が100%になると、システム全体が重くなります。
100%になっているようであれば、しばらく待つなりします。

 しかし設定したパソコンではハードディスクへのアクセスはそれほど多くありませんでした。
 じゃあ最近はあまり無いけどCPUが原因かなぁ?と見てみても
CPU使用率は30%程度で余裕がある表示でした。 

この時点で「あれ~?」という感じでしたが、再起動してとりあえず続けて設定してみます。
初期設定直後では調子が悪く重いということがあります。
その時は再起動すると直るということがありますが、今回はあてはまりませんでした。

セキュリティソフトを削除
→すげー時間かかる。
プリンタを設定
→すげー時間かかる

設定中は重くて時間がかかるものですが、これでは普段使用でもストレスを感じてしまうでしょう。
やはり何かがおかしい。
何が原因かとタスクマネージャーを見続けていると、ある特徴に気づきました。

CPUの周波数がずっと0.5GHzのまま動かない。 

なにをやっても動かない。たまに一瞬増えることがありますが、ほんの一瞬です。しかもほんとに一瞬。
これは・・CPUが怪しい。
CPUは「Intel Celeron N2830」
最大周波数は2GHzを超えますし、デュアルコアです。それほど悪くありません。
(AMD E1プロセッサなんて1GHzしか出ないものがあって重いし、それに比べたらもう・・)

しかし実際には、ずっと0.5GHzです。 
なので「Celeron N2830 0.5GHz」というキーワードで調べてみました。

あまり検索結果は多くありませんでしたが、回答がありました。
どうやら電源オプションで「バランス」が選択されていると、0.5GHzしか出ないようです。

電源オプションとは、ノートパソコンの場合は右下の電池マークか、
コントロールパネルから行くことができる設定項目です。
CeleronN2830遅い件_003


 












ここですね。
大体は、「バランス」「省電力」「高パフォーマンス」という項目があり、
初期状態では「バランス」が選択されていることが多いです。

選択されていた「バランス」から「高パフォーマンス」に変えてみます。
はい。
見事に2.4GHzで動き始めるようになりました。
すると先ほどの重さは嘘のようにさくさく動くようになりました。
設定も、ネット閲覧も。
新しいセキュリティソフトを設定しましたが問題なく設定出来ました。 

CPU「Intel Celeron N2830」が原因でした。)
まったくAMDがしょぼいCPU作るとIntelが怠慢になるのは低消費電力CPUも同じようです。
今回はCPUというより設定が問題だったのかもしれませんが。

とりあえずパソコンを作ったメーカーさんはちゃんとテストしたのか甚だ疑問です。
テストしたらパソコンが重いの分かるだろうに。
動いたからOK、ということにしたんでしょうか。
初期設定を「高パフォーマンス」で出荷するべきでしょう。 

最近パソコン買ったんだけどなんか重いなぁ、という方の参考になれば幸いです。
もし最近「Celeron」を搭載したノートパソコンを購入した方であれば、
こちらに書いたことに該当するかもしれません。


~~~~
ここからは蛇足・・原因について

さて、今回「高パフォーマンス」設定で症状が改善しましたが、
実はなんで「バランス」から「高パフォーマンス」にすると周波数が上がるのかよく分かりませんでした。

電源オプションには細かく設定できる項目があり、その中に「プロセッサの電源管理」というものがあります。
CeleronN2830遅い件_004


























これです。

この中に「最小のプロセッサの状態」「最大のプロセッサの状態」というものがあります。
これは(恐らく)あんまり処理が無い時はCPUの周波数を落として(最小のプロセッサの状態)省エネして、
処理が多い時は周波数を最大(最大のプロセッサの状態)にして処理をこなそう、というものだと思います。

実は設定したパソコンでは、「高パフォーマンス」でも「バランス」でも、
「最大のプロセッサの状態」はきちんと100%に設定されていました。

本来であれば「バランス」でも、初期設定などをしていて処理が多くなったら、
周波数がちゃんと上がるはずです。が、0.5GHzのままでした。 
これは謎です。

ですが、少し調べたら以下のサイトさんを発見しました。
少し古いノートPCにWindows8を入れたらCPUが本気を出してくれなくなったときの対応方法 

こちらのサイトさんによれば、どうやら電源オプションには隠し項目があるようで、
もしかしたらこの項目が「バランス」と「高パフォーマンス」で違うのかもしれませんね。

 

変なマザーボードを入手しました 【型番:MGM965K2R (K5260の中身)】

最近余っていたノートPC向けのCore2Duoをなんとか使えないかと、ヤフオクでマザーボードを入手しました。
型番は「MGM965K2R」。
これは富士通の法人向けデスクトップパソコン『FMV-K5260』に内蔵されているマザーボードです。
http://www.fmworld.net/biz/fmv/esprimo/0804/k5260/

以下のサイト様を参考に導入しました。ありがとうございます。

今回買ったMGM965K2Rではないのだが、すごく似ている「MGM45M2R」について書かれたページ
http://p53ka.blog69.fc2.com/blog-entry-110.html
http://p53ka.blog69.fc2.com/blog-entry-147.html

K5260のドライバについて書かれたページ
http://blog.goo.ne.jp/rezoochi/e/fcbb7fbf7ec5f9b635f49db2a78f31f8

実際の製造メーカーはGIGABYTEですが、メーカー向けのマザーボードだけあって特殊なマザーボードのようで、少し戸惑いました。先のページにも書いてあるのですが、私なりの導入手順をまとめておきます。

大前提として、以下のパーツが私の手元にありました。それを流用しました。
・Core2Duo T7250 (2GHz / L2 2MB)
・DDR2 SDRAM SODIMM 1GB×2枚
・SATA 5400rpm HDD 80GB
・Celeron2.4GHzのリテールCPUクーラー(Pentium4の2.53GHzに使用していたものです)
しかし、これだけでは使うことができません。

まず、CeleronリテールのCPUクーラーはそのまま設置することができます。Socket478世代のCPUクーラーを載せる台がついているためです。しかし、ただ載せただけでは隙間が出来るみたいでうまく冷えません。

どれくらい隙間があるのかな、ということでティッシュをつめてみたりしてなんとなく隙間の測ってみました^q^ だいたい1mm未満の隙間がありそうだったので(正しいかは不明です・・)、ホームセンターで1mmのアルミ板を買ってきて、それを挟むことにしました。参考先のサイトでは銅板を挟んでいるようでしたが、安かったのと、銅と比べれば熱伝導性が落ちるけど、他の素材に比べれば良いからという素人考えでアルミ板にしました。大きさは1cm×1cmです。これはCPUのクーラーにあたる部分が1cm×1cmくらいだったからです。
さらにPCショップで、グリスの代わりに挟んで使う熱伝導シートを買ってきました。これは単にグリスを塗るのが面倒だったからです(

これらを熱がうまく伝わるように、
CPU=シート=アルミ板=シート=CPUクーラー
という順番でサンドウィッチしました。

次に、このマザーボードにはCPUクーラーのファンの電源ケーブルを刺すピンがついていません。というわけで、PCの電源についてる4ピンコネクタを、ファンの電源コネクタに変換するケーブルを買って、そこにファンの電源ケーブルを刺しました。
http://www.yodobashi.com/ec/product/100000001001097152/index.html
こんなのです。

さらに、このマザーボードにはスイッチ用のピンがついていません。参考先のサイトに書いてあるように、F_HEADERのあたりをちょちょいとショートさせれば電源がつくようなので(コメントによると2番目とGND?)、ショートさせるためのリード線を買いました。線なかったので・・。
http://www.yodobashi.com/ec/product/100000001001102924/index.html
細いのがいいだろうとこんなの買ったのですが、細い銅線をより合わせてある線なので、ショートさせようとするときにあっちこっちに銅線が向いて、ショートさせにくかったです。ただの針金のほうがいいかも?
とはいえショートさせるのは最初の一度だけですむので(後ほど説明)、今はストレスはありません。

あとは、このマザーボードには、SATAとIDEが刺せるようになっていますが、OSを起動できるHDDはSATAに刺したHDDだけです。IDEに刺しても起動はできません。DVDドライブを刺して、DVDに入ったOSやらインストールのディスクやらは起動できます。また、IDEにHDDとDVDドライブを同時に刺すとどっちも認識しなくなりますので注意が必要です。

これらを全部くっつけるとこうなります。
DVC00002

あれ、なんか明らかにおかしいなと思いますね、はい。
これまで使っていたPCケースの上に載っております。
板は150円くらいで買いました。
これで使えます!(

上から見るとこんな感じ。
DVC00024

私は最初からこう使う予定だったから試していないのですが、ATXのPCケースには設置できないかもしれません。特殊ですからね。

さて、電源をいれましょう。
電源を入れると(まずはピンをショートさせます)、ピピッとブザーが鳴って、「ファンエラー」と表示されて、とまるはずです。音が違ったりエラーメッセージが違う場合は何か別の問題が発生しているかもしれませんね。

ここで「F2」キーを押してBIOSを表示させます。
どこかに「AC電源を入れたときにどうなるか」(詳しい文言を良く覚えていない\(^o^)/)ってな感じのメニューがあるのでそこで「電源ON」を設定しましょう。
そうすると、AC電源を入れれば電源がつくようになります。もうショートさせる必要はありませんね。

先ほどのファンエラーのところでF1を押せば先にすすみます。
私はここで最初にWindowsXP SP2をインストールしました。

次にドライバの導入について。
と、その前にこのマザーボードの構成について書いておきましょう。

Intelさんのなんかのユーティリティで表示した結果です。
MGM965K2Rチップセット情報

Intel® Chipset Identification Utility
System Information
 Chipset
 
Detected Chipset:
 Intel(R) GM965 Express Chipset
 
Chipset Components
 
Memory Controller:
 82GM965
 
I/O Controller:
 Intel(R) 82801HBM/HEM I/O controller hub (ICH8M) SATA Controller found in IDE mode
 
Integrated Graphics:
 Intel(R) 965GM Graphics And Memory Controller Hub(GMCH)
あと、富士通のマニュアルに、ネットワークチップ?の型番が書いてありました。
Broadcom BCM5786」です。
これらを参考にドライバを以下の順番で導入しました。

1.KB888111の適用
これはサウンド関係のバグ修正のようです。これを入れないとオーディオがPCI Deviceに見られちゃって、サウンドのドライバを入れても、音が出ません。

まず、http://support.microsoft.com/kb/888111/jaから辿っていって登録して、メールで送られてくるURLから、「216954_intl_i386_zip.exe」を入手→解凍します。

「KB888111_Supported_OS_All_Languages」→「jpn」→「x86fre」にある「kb888111xpsp2.exe」をインストールします。OSがSP2なのでsp2.exeを入れました。臨機応変に変更してください。

※OSがSP3だと面倒なことになるようなので、SP2以前のときがおすすめのようです。SP3の場合は、別途調べてください。


2.ビデオドライバの適用

モバイルインテル965のページ(http://www.intel.com/p/ja_JP/support/highlights/chpsts/965m
の「最新ダウンロード」欄のところから、ダウンロード一覧のページ(リンクがアラビア語で書いてあるかもしれない)に行き、バージョン「14.37.4.5218」の「Intel® Graphics Media Accelerator Driver for Windows* XP (exe)」を選択して、「winxp_14374.exe」を入手→インストールします。


3.ネットワークドライバの適用

Broadcomのページ(http://ja.broadcom.com/)→「ダウンロード」→「ドライバのダウンロード」
を選択して、下のほうの「NetLink 57xx」の「Download drivers」を選択します。
(Download drivers for the following previous generation Ethernet chipsets:
5781, 5786, 5787, 5788, 5789 とかいてあります)

Vistaのドライバしか出てこないので上の方にある「archive page.」を選択して、
「Windows XP (32 bit)」のリンクを選択します。
そして「win_xp_2k3_32-14.8.0.5a.zip」を入手→解凍します。

「デバイスマネージャー」の認識されていないネットワークデバイスなところで、「プロパティ」→「ドライバの再インストール」とやって、解凍された「win_xp_2k3_32」のフォルダを指定してインストールします。


4.サウンドドライバの適用

「FMV-ESPRIMO」の2008年4月~9月モデルのページ(http://www.fmworld.net/biz/fmv/support/download/2008_1/desktop/)から「K5260」「WindowsXP」の「ダウンロード」を選択します。
「Realtek High Definition Audio Driver for Windows XP/2000」を選択して新しいページを表示して、ダウンロードリンク「Realtek High Definition Audio Driver for Windows XP/2000」を選択します。
「E1009695.exe」を入手。実行して解凍します。

解凍してできたフォルダ「XpRH5886.web」にある「Setup.exe」をインストールします。


5.INFアップデートユーティリティの適用

モバイルインテル965のページ(http://www.intel.com/p/ja_JP/support/highlights/chpsts/965m
の最新ダウンロードのところからダウンロード一覧のページ(リンクがアラビア語で書いてあるかもしれない)
に行き、バージョン「9.3.0.1019」の「インテル® チップセット・デバイス・ソフトウェア (INF アップデート・ユーティリティー)」を選択して、「infinst_autol.exe」を入手、インストールします。

「5.INFアップデートユーティリティの適用」に関しては、他のドライバインストール前にいきなりやると、USBが認識しなくなるみたい?です。一番最後にやったらUSBを認識しました。

以上が私が行った導入方法です。
この時点で不明なデバイスが3つほど残りますが、一般的な用途ではそのまま使えるはずです。

参考先サイト様にも書いてある内容ではありますが、
これからこのマザーボードを導入する方の参考になれば幸いです。


GeForce6600のポリゴン欠け・伸びについて

最近、今は昔の旧世代GPUのGeForce6600GTをお安く手に入れたわけですよ。
古くてもGPUということで喜んでベンチマークを動かしたんですが(もちろんその当時の)、
ポリゴンが伸びる・欠けるといった現象が発生して見れたもんじゃない。
手に入れた当初(1ヶ月前?)はそんなに酷くなかったとおもうんだけど、
ここ数日ベンチを動かしてみたら酷いのなんのって。

巨大な戦艦(母艦?)のはずなのに巨大なポリゴンが移動してるようにしか見えなかったり、そこから飛び出てくる多数の揚陸艇はポリゴンが伸びてとげだらけになってたり。お前らはウニかっ。
(宇宙の話です)

いろいろ設定してみたけど直らない。
熱暴走かと思って温度計測してみても、最大84度くらいしかいかない。十分高いけどそこまで高いか?と。
もしかして前に熱上がってぶっ壊れたか?と絶望感に苛まれたりしました。

が、治りましたよ!
ドライバを入れなおして

最新版からバージョンにして186.45低いドライバを。
最新版バージョンは280.26ですが、入れたのはバージョン93.81です。

GPULoadやVRAM使用率などが見れなくなるといった機能低下があったり、NVIDIA設定・コントロールパネルが英語になったりしてしまいましたが、ポリゴンの欠け・伸びは解消しましたヽ(´◉◞౪◟◉)ノ

公式では古くてもバージョン197.13までしか配布されてないので、
バージョン93.81は以下のページからダウンロードしました。
http://www.nodevice.jp/driver/GeForce_6600_GT/get37228.html

もしかしたら設定で治ったのかもしれませんが、治ったのでいいです(
もし古いGPUで表示がおかしかったりしたら、最新ドライバーではなくて、古いドライバーを入れてみるといいかもしれませんねっ。

追記:
以下のページにちょっと新しいバージョン94.24がありました。
http://www.nvidia.co.jp/object/winxp_2k_94.24_jp.html
こちらを入れても、ポリゴンの欠けや伸びは発生しませんでした。
コントロールパネルが日本語になっていますので、入れるならこっちが良いかもしれません。
記事検索
livedoor プロフィール
QRコード
QRコード

トップに戻る